Orel ESCs not working


(mike kelly) #1

I first apologize for not really knowing what I am doing. With that said…

I have setup 4 ESCs, to be used eventually with Arducopter, using UAVCAN GUI.
Firmware 2.2 …73
Static addresses assigned 100,101,102,103
esc_index 0,1,2,3
light_index all set to 0, not sure what this is for.
all parameters from all ESCs stock otherwise and identical.

When I power up all ESC lights go from purple to yellow to green and the Motors “chirp”

ESC with node ID=100 works fine. Go to ESC panel and it spins up.
All other Motors just cog a bit, shift a few degrees back and forth.

Occasionally when I try to “fetch all” on any of the ESCs it times out and fails to fetch the values.

No errors in the transport stats.

BTW I did test the motors with a common PWM ESC and they work fine.

Thanks for any troubleshooting insights.


(mike kelly) #2

I found the problem. When I got the motors they had screws that were not in sealed packages which made me a little suspicious but since they came with the motors I used them. They cleared and caused no shorts in the motors and one motor worked fine and another with a PWM ESC worked fine. But just to cover my bases I took it everything apart and replaced all the motor screws with shorter screws. Everything works fine now. The screws must have been just long enough to affect the magnetic fields in the motor, that the Orel detected?
I don’t know but everything is working now as expected.


(Pavel Kirienko) #3

@mike_kelly Mike, sorry for the late reply, I’m traveling. Glad that the issue has been resolved. It would be great if you could post a couple of photos of your motors with the screws that cause troubles so we could try and investigate it for the benefits of posterity. If you can’t do that, that’s fine, too.

Nicholas told me that you would like me to remove this post. If you’re still keen to do that, you should be able to use the website’s interface for that now (you should have the delete button visible now). Alternatively just tell me that you still want the post removed, and I’ll remove it for you.


(mike kelly) #4

No problem at all. I just thought it would not be good to have a post with that title when the Orel was not to blame. You know how people are at jumping to conclusions rather than reading the details.

Very interesting that the screws were not actually touching but they clearly influenced the situation.

Just to let you know I wrote a little intro to UAVCAN GUI to help beginners.

Cheers


(Pavel Kirienko) #5

Thanks Mike. Having this post published is fine, I think.

Would you be able to post the photos here please?


(mike kelly) #6

This problem was not the fault of the Orel ESCs. These are T-Motor 3110-470kv motors. The 8mm long mounting screws do not touch the windings, they spin freely and there are no marks from the screws rubbing on the windings yet they cause the motors not to spin. I do not know if the Orel ESCs detect a problem with magnetic fields and go into a protection mode?


If the screws are shortened from 8mm to 5mm everything works fine.


(Pavel Kirienko) #7

Thanks Mike. Indeed, it seems like the screws could cause a significant distortion of the magnetic field, which rendered the motors dysfunctional. Perhaps @dmitry.ramensky could offer more insights on this.


(mike kelly) #8

I learn something new about this activity every day!

Thanks for your work on UAVCAN and for producing the Orel ESC. I am converting a 3DR Solo to completely UAVCAN, with Orel ESC, OlliW Power Module, GPS and Mag then finally the STorM32 gimbal controller interfaced UAVCAN. It is now all working with Arducopter and I just need to assemble it and see if it flies.

All the best


(Dmitry Ramensky) #9

Mike, Orel ESC in opposite to convential ESCs detects commutation moments rather precisely. It ensures more efficiency of the ESC. Unfortunately this algoritm is sensitive to motor magnetic field distortions. Screws distort magnetic lines. It leads to commutation moments biasing, like shown in the figure.


(mike kelly) #10

Thank you Dmitry,

My test certainly confirms your theory. Everything about the Orel requires new thinking vs older traditional ESCs.


(mike kelly) #11

Still having problems. I just powered up the multirotor today and esc_index=0 is doing the same thing during the motor test. All the other ESC’s are ok except 0. I removed all the screws from the motor and it still does the same thing. It is slightly different than before because before they would all move one direction for a couple of degrees and then return, now it goes in the same direction but in steps and only a few degrees around the rotation. UAVCAN GUI looks pretty normal to me, no communications errors. This ESC/Motor was working fine when I last turned it off. THe ESC passes diagnostics and the light is green solid on.


(Pavel Kirienko) #12

Hi Mike,

Please swap the motors between the failing ESC and a healthy ESC and see what changes. Thanks!


(mike kelly) #13

I did not do what you asked because I don’t want to disturb a working ESC-Motor pair. But what I did do is remove the motor from the ESC in question and soldered on a new Motor. The new motor worked fine. Then I unsoldered that motor and put the original back on. It did not work,just as before.

Then I took that seemingly bad motor and hooked it up to a standard PWM ESC and it works fine. It is a brand new T-Motor 3110-470kv.

Pretty weird to me…


(Pavel Kirienko) #14

Perhaps the failing motor was soldered to the Orel improperly? Could you please solder it back, triple check the soldering work and try again?


(mike kelly) #15

Remember I already did that. I removed the “bad” motor, and soldered on a new motor. The new motor worked. I then removed it and resoldered the old original motor and it still did not work. I then restored the replacement motor and it again worked.

Then I took the apparently bad motor and connected it to a traditional PWM ESC and it ran just fine no problem.


(mike kelly) #16

BTW This all started when I powered up from battery orignally and one of the ESC’s started to smoke. I bought a replacement and sent the burned one to Nicholas at Titan Elite. It appeared to me that the problems looked like they were connected to the CANbus interface. I had to replace a number of other devices on the CANbus that had their CANbus transceivers toasted. Have you gotten any feedback from NIcholas after looking at the burnt ESC?


(Pavel Kirienko) #17

I did not do what you asked because I don’t want to disturb a working ESC-Motor pair.

How critical is it for you to not disturb a working pair? It could provide useful information about your issue.

It is possible that there are other factors affecting the behavior of the failing ESC. Was it connected via UART or RCPWM during the test? Could you share the configuration parameters of the failing ESC and a healthy ESC?


(mike kelly) #18

I was just hoping to get this up in the air to prove it works. My whole test is all UAVCAN. I have converted a 3DR Solo to use your Orel ESC and OlliW UAVCAN Power Brick and GPS/MAG. I worry about soldering and unsoldering the ESC’s.

I can send you UAVCAN GUI recordings, I have them already but everything looks ok to me.

Actually I guess it does not matter because it looks like there is a bug in the PX4.V3 platform in Arducopter where if I have UAVCAN enabled the compass no longer works, even your GNSS. I have both OlliW’s GPS/MAG and your GPS/MAG. Neither works when UAVCAN is enabled. Even an I2C mag does not cal in mission planner or anywhere else when UAVCAN is enabled.

I have captured the parameters of all the ESC’s and diff’ed the files and they all look the same. But I can send them to you. There are lots of parameters I don’t understand.


(Dmitry Ramensky) #19

Well, we are waiting for captured parameters from ESCs. Mike if it’s a problem to change motors, could you please remove the motor from the ESC one more time? Measure with multimeter resistance between it’s phase wires. Do same measurements for the new motor and compare.


(mike kelly) #20

Sorry Dmitry, I plan to do the full test for you and provide the logs but I have been troubleshooting problems with UAVCAN on A

OK esc 101 was the problem. I removed motor from esc 100 and installed the ‘bad’ motor. The result was “bad” motor still bad. Then I removed “good” motor from esc 101 and installed “bad” motor. “Bad” motor still bad. CAptured UAVCAN Bus traffic. But remember the “bad” motor still works fine on a traditional PWM ESC.

I tried to upload the files but this forum is not set to accept zip files or text files! So I am unable to supply them. I have them ready tho.