Homepage Knowledgebase GitHub

Mitochondrik/Telega Queries

Hi,

We have a curious issue with our implementation of the mitochondriks. We are unable to get stable operation under any sort of ‘aggressive’ settings when using the ESCs in voltage control mode.

Following the myxa quickstart guide, we have set the following:
m.voltage_ramp = 50
m.eangvel_accel = 15000
m.eangvel_decel = 10000
uavcan.esc_rcm = 2
m.current_ctl_bw = 0.01

Essentially when given fast and aggressive step impulses (0-90,100%), we are able to cause the ESC to (presumably) loose sync with the motor, and essentially cause the motor to stall and make a horrific (also presumably) cat-killing noise whilst it does this. The issue is that this can happen whilst the aircraft is in flight, making 4x versions of these aircraft quite problematic.

The only way we have been able to get any sort of reliable, extreme operation out of this is to increase the current sense resistor from 0.001Ohm to 0.003Ohm (which makes the aforementioned settings work). Or reduce the voltage ramp to 20, and significantly reduce the m.current_ctl_bw to 0.005 to gain any sort of stability.

In essence, increasing the resistor seems to have the desired effect and we can operate the ESC reliably in all our scenarios. This is not ideal in that we do not want to fix all our ESCs to fix this issue. Given this is a configurable parameter, is there anything that we can do to gain some stability with the current system? Or anything else we can do to try to fix this?

This brings up a secondary issue. In light of reading other posts, we updated an ESC with the V0.3 of the telega firmware, which works - however it has removed the FET and current shunt parameters, upon realizing this we tried to downgrade this, and the mitochondrik goes into a boot loop. Can you advise what we are to do here? The V0.3 runs motors fine (previous considerations aside) Just we cannot adjust the required parameters.

Related to this, we are trying to calibrate a motor through the CAN interface based on this message here:


I assume you actually mean 1002 (decimal) not 0x1002 (hex)?
Is there a list of useful commands we can run from here? We have been running 1000, and 1001 to achieve the same effect. Though this was only through looking at related projects did we discover that.

Best Regards,

Hi Anton,

There are two parameters that need to be adjusted in the voltage control mode to improve the step response. They are described in this post. Increasing the current sense resistors reduces the noise. It allows to increase the current m.current_ctl_bw.
If you don’t want to increase the resistance you can try to increase the parameters o.ekf.q_id and o.ekf.q_iq for example up to 14000 and 33000.

The v0.3 release doesn’t fully support the mitochondrik unfortunately. Please upload the latest stable firmware version supporting all Mitochondrik’s features com.zubax.telega-1-0.3.ab5f2ae9.application.bin (265.9 KB).

Yes, the command is 1002 (decimal). There’s no more commands now. But they willbe added later.

Cheers Dmitry,
Thanks for the clarification. I will get this tested.

Best Regards.