Mechanical noise while testing with Multistar 4822 690KV

myxa

(Denis Rono) #1

Hello,

We are running the Myxa with a Multistar 4822 690KV motor. We have changed the parameters to suit multirotor applications as per the quickstart guide. We have set the following parameters:

  • eangvel_accel = 15,000
  • eangvel_decel = 10,000
  • Maximum current = 40A
  • max_eangvel = 14,000 (for a maximum mechanical RPM of 12,000RPM)
  • We are using RCPWM to control the motor.

We connected the motor up to the thrust stand and we are getting a strange mechanical noise above 10,000 RPM (see video )

Have you come across this before? What could be causing this noise?

Attached are the configuration settings we are using. Let me know if you need more information.

We have come across a different issue with the a different Myxa; We have run the Myxa with this motor in the past and have not heard any mechanical noise however, in those cases, the RPM seemed to max out at around 11,000 RPM and would not increase regardless of throttle input. Can you please provide suggestions as to what might be causing that?

Your assistance with the two queries above will be much appreciated.

Thank you


(Pavel Kirienko) #2

Hi Denis,

Apologies for the delayed response.

The noise is due to the fact that during the test Myxa is pushed beyond the maximum current frequency where stable operation is possible, which is currently limited at around ~1.6 kHz (or ~100k electrical RPM). You are using a 22-pole motor, which means that at 10k mechanical RPM the electrical frequency exceeds 10kRPM * 22poles/2*60s = 1.8 kHz.

The problem will not appear when the propeller is attached, since that would naturally limit the maximum frequency.

An insufficient supply voltage is the most likely reason.


(Denis Rono) #3

Hi Pavel,

Thank you for the response. Your explanations match our observations. Regarding the current frequency, is there a way to increase this in the settings?

We have been able to fly a hexacopter with the Multistar 4822 690KV however the drone was not stable. It was oscillating a lot. We do not think the PID gains on the flight controller (Pixhawk cube) require changing. We were wondering if the PID gains in the ESC must be changed. Do the PID gains in the ESC need to be changed when a motor with 22 poles is used?
We have flown with EMAX MT3515 650KV (14 pole) motors which were stable with no need for PID tuning which suggested moving to a motor with more poles requires PID tuning.

Thanks


(Pavel Kirienko) #4

No. The constraint is due to the limited processing power of the CPU, it is not possible to change that.

You seem to be misunderstanding how Myxa works, which is important to rectify before you proceed with further testing. According to the screenshot, you are using the voltage control mode. As explained in the quick start guide, the PID controller is only used in the RPM control mode. Since that is not used in your case, the PID settings will have no effect on the operation of the ESC. You can picture the inner control loops per operating mode as follows:

In the RPM mode: RPM setpoint --> RPM PID controller --> current setpoint --> current controller --> voltage setpoint --> motor

In the current control mode (not suitable for fixed-pitch multirotor vehicles): current setpoint --> current controller --> voltage setpoint --> motor

In the voltage control mode: voltage setpoint --> motor

If you are using Myxa with a multirotor vehicle, the voltage control mode might be the best choice excepting certain special scenarios. In this mode, the only parameter governing the bandwidth of the controller is the voltage setpoint slope limit, which is set via the parameter m.voltage_ramp. You seem to have left it at its default value, which is rather conservative. Consider increasing it up to about 25 volt/second.

This observed relation between the bandwidth and the number of poles is incidental and should be ignored.