Dumb Question about the on board Baro


(Richard Gardner) #1

Just ordered my first Zubax GPS, so be gentle this is my first question.
I am replacing a I2C based compass and standard GPS due to what I think is I2C noise giving me all kinds of grief with the compass. Can Ports are less susceptible to the noise issues I am experiencing, so I bit the bullet and ordered one.

Here is my first question. I have a arducopter (Pixracer) build and noticed in the documentation that the Zubax has an on board Baro. What if any advantage is there to using this barometer versus the FC mounted Baro, or do you use both at the same time. Sorry never really understood this.


(Pavel Kirienko) #2

Certain flight controllers such as PX4 support multiple barometers for redundancy. Not sure if this is the case with ArduPilot (consider migrating to PX4, its CAN stack is better supported).

The advantage of external barometer is that in certain airframes the GNSS unit is located away from areas affected by the prop wash, which improves altitude and climb rate estimates.


(Richard Gardner) #3

Thanks Pavel.
Honestly I have no idea how to migrate to PX4 but I guess I need to do some research.
As for the location of the GPs, its hidden in the air frame so prop wash isn’t a concern.

Thanks again. Looking forward to giving it a try.

cheers


(Richard Gardner) #4

Pavel.
Sorry one more dumb question…please don’t laugh lol
In a typical UART GPS you connect TX to RX and RX to TX.
In the Can port version…is it High to Low and Low to High …basically the same connection method.

Also what Command line tool do you recommend.

It still hasn’t arrived but should be here soon. Can’t wait.


(Pavel Kirienko) #5

CAN is not point-to-point, it’s a bus. You connect High to High and Low to Low.

For CLI, consider using picocom if you’re on GNU/Linux, otherwise use PuTTY.

For CAN configuration & setup use the UAVCAN GUI Tool: http://uavcan.org/GUI_Tool


(Richard Gardner) #6

Thanks Pavel. I forgot its a bus…makes it simpler to setup.
I have putty so I can go with that,
As for Can Config, I think I just need to set the uavcan.node_id to some random number thats not 1…like 50 in the documentation.
uavcan.node_id = 50
BRD_CAN_ENABLE to 2
GPS type to 9
Compass is external and primary…no rotation.

I think thats it. Man I wish it would hurry up. The reviews I have read and the video I have seen say this is an outstanding GPS. I can’t wait to give it a go.


(Hrvoje) #7

Hi Richard!

In your first post you mentioned you have issues with compass and in a later post you mention that your GPS is mounted inside your frame, it that correct?

As I do not know that size and type of your frame this is just a guess but it is possible that your compass performs badly because it is too close to your PDB, main power lines or some other strong source of interference/noise.

This is one of the most common sources of issue with compass modules, which is why it is generally recommended not to use compass that comes mounted on flight controller. It is usually positioned close to source of interference and sometimes generates too much noise itself.

Standard recommendation for quadrotors and similar vehicles is to buy a GPS unit with inbuilt compass and mount it as far as possible from other electronics.


(Richard Gardner) #8

Hi there and thank you for your response.
Yes your correct I am having compass issues, the GPS itself works like a trooper but the compass not so much.
I originally looked at the Zubax because I had run out of UART ports and wanted dual GPS for better accuracy. However after reading the literature and watching the reviews on Youtube I quickly realized that the Zubax out performed most other general GPS. So I put it on my list as a possible solution. However I soon solved the UART problem and shelved the Zubax idea.

Once the machine was air worthy I took it to the field and test flew it. I then performed a review of the logs and much to my surprise was finding Compass health issues. After a couple weeks I traced it to a faulty I2C hub. Replacing the hub solved the health issue but I was left with the inability to properly calibrate the compass.

I came to the conclusion I had 1 of 2 problems…or possibly both. First I2C line noise as there are a number of I2C devices and second, Nearness to high power leads. The GPS/Compass combo is under a plastic canopy and with the canopy off the same errors occurred. I even replaced the GPS/Compass with another and the problem still continued. At this point I decided to do two things. Not wanting to just do a half ass job on it. I orderd the Zubax GNSS and tore the machine down. I have since redesigned the top plate of the craft and will move the GPS/Compass to the rear of the craft away from as much wiring as possible, move the PDB to the front of the machine and switch to the GNSS to remove the I2C line as a possible cause.

As for the FC Compass, I never use it however in this instance its the only compass I could successfully calibrate…go figure.

So in the next couple weeks I will reassemble the machine and see how it goes after that.
Here is a photo of the machine in its assembled state, before I stripped it


(Hrvoje) #9

That looks pretty cool! Changes you are making sound very reasonable, best of luck with it and let us know how it goes :slight_smile:


(Richard Gardner) #10

EDITED BY MODERATOR: see the discussion here: GNSS GPS on Pixracer

Hey guys.
Last night I installed my GNSS v2 GPS. It’s all powered and connected to the Pixracer.
I have a termination plug in the second port so I figure I should be good.
I set the GPS type to 9 and rebooted. NO GPS.
So then I read that if there is a redundant port it needs termination as well. So I made up another termination plug and put it in.
NO GPS.

So to make sure I did this right. There is Can Port one with 2 ports and then CanPort 2 with 2 ports. I have terminated one of each of the Canports. Is this correct. IF so I wonder what I am missing.