GNSS GPS on Pixracer


(Richard Gardner) #1

Hey guys.
Last night I installed my GNSS v2 GPS. It’s all powered and connected to the Pixracer.
I have a termination plug in the second port so I figure I should be good.
I set the GPS type to 9 and rebooted. NO GPS.
So then I read that if there is a redundant port it needs termination as well. So I made up another termination plug and put it in.
NO GPS.

So to make sure I did this right. There is Can Port one with 2 ports and then CanPort 2 with 2 ports. I have terminated one of each of the Canports however I don’t think this is needed, I think the single termination is sufficient on the port thats in use. So the question is, what am I missing

I don’t think I need to set BRD_CAN_ENABLE to 2 because I think its Px4 specific, so then I am not sure what I need to do to get the GPS seen.


Dumb Question about the on board Baro
(Bryan Monti) #2

Hi Richard,

After the reboot, what did you see on the GNSS regarding LED status? (Any CANx LEDs on?)

You don’t need to terminate CAN2 if you are not using CAN2 (although, I don’t think this could hurt). Just terminate CAN1.


(Richard Gardner) #3

Hey Bryan.
I didn’t flip the GPS over but I did see a red blinking LED on the GPS. I don’t know if this is what your referring to.
I didn’t think I needed the second Terminator.
I will remove it.

but it still shows GPS_Status =0 which means no GPS
By the way both GPS_Type=9 have been set to be safe.


(Bryan Monti) #4

Check to see if the CAN1 LED is blinking or solid (it is a green LED) on the GNSS. The red Status and PPS LEDs should be blinking ~1Hz.

I’m not too familiar with APM but if there is a way for you to access the MAVLINK shell and check the uavcan status running, that would be a good start.


(Richard Gardner) #5

Its a red blinking LED. I will flip it over tonight and see what other LED’s are there if any.
As for access to the Mavlink shell…I have no clue how one would do that.


(Bryan Monti) #6

Regarding Mavlink shell (or rather, NSH): http://ardupilot.org/dev/docs/interfacing-with-pixhawk-using-the-nsh.html

The LEDs have labels next to them. Look at them and refer back to my previous statement.


(Richard Gardner) #7

So interesting, I confirmed that the red LED was blinking. No other LED was.
I removed the termination plug from the second port, no change.
I checked the Serial ports for any any legacy setting. Two serial ports where set to GPS. I corrected that.
No change.
Then I happen to see BRD_CAN_ENABLE set to 0 and went…what the heck, corrected it and bingo.
Oddly I got a bad baro health error for a while and eventually that cleared. At least so far.

I have not enabled the Zubax Baro. Not sure if there is any advantage in my case as the GPS and the FC are on the same lever inside a canopy.

Now I just need to try the compass calibration to make sure thats all good and then work to clear all the other issues I have on my list.


(Richard Gardner) #8

dang checked the machine this morning before work. Bad Baro health. I have never had that issue before and to my knowledge I am not using the GNSS baro unless it now works automatically.
There was never a baro issue prior to the GNSS being installed…thoughts anyone.


(Bryan Monti) #9

Hi Richard,

Not sure about the baro health. Do you have any way of connecting to the MAVlink shell (NSH) as described earlier and checking if the baro is being used by the system when you check uavcan status ? ie, it is publishing data to the system.

Otherwise, it is working as a GNSS at the moment and either the CAN1 or CAN2 LED, respective of cabling, is working?


(Richard Gardner) #10

Hey Bryan.
Thanks for getting back to me. I have not tried the NSH thingy yet.
But let me tell you what I did…Surprise.
I rolled the code back to a 3.4x version…sorry didn’t note exactly what version it was…just a previous one.
Rebooted and bingo…no baro health issue…at least not so far.
The GPS is working.(I have not taken it outside to see if it gets a lock yet.)
The compass calibrated first try…
The machine calibrations are now all done.
I have a lidar issue to resolve but I know whats wrong there…so thats easy.
I will now get her outside and watch to see if the baro issue comes back…If not it’s remaiden time coming up.
The idea of moving to the GNSS GPS seems to have been the right decision, I struggled with compass issues and this just worked first time. Wa hoooooooo

I know more testing is still needed.

Thanks…will let you know how it goes.


(Richard Gardner) #11

Played with the Pixracer firmware today. I went forward to 3.4.6 and it works fine. If I go to 3.5.x no go there is a Baro Health issue. Not sure how to report that as a regression error. But it appears to be one.
I checked to see if there was any other code via mission planner available and after this it’s a 3.5x version and the barometer isn’t working in that code.


(Pavel Kirienko) #12

Consider reporting here https://github.com/ArduPilot/ardupilot/issues


(Richard Gardner) #13

Thank you. I reported it.
I found others with the same issue but didn’t find a bug report…so I opened one.


(Richard Gardner) #14

Hey guys do you have to set the node ID. Sorry but I am getting confused on this.
I have a working GPS and compass with no id set yet I see it has to be done in 3.6 so I am confused.

Edit I have since updated the Node_ID to 42…figured that out…now I am wondering if I need to set uavcan.pubp-pres to 50000 to get the baro to work

Edit I set uavcan.pubp-pres to 50000
I set Uavcan Node_id to 42

No go


(Pavel Kirienko) #15

Please make sure that the autopilot is configured to use the external barometer. They should have documented that somewhere; if not, raise an issue. The UAVCAN support in ArduPilot is quite poor still.


(Richard Gardner) #16

Ok i installed PX4.
I see the setting for UAVCAN and set it to 2 Sensors only. The gui after reboot says GPS Count 0. Hmmm…that doesn’t seem right to me.

Mind you I also notice the artificial horizon doesn’t move when I tilt the craft, the voltage reading doesn’t appear.
Lidar isn’t working…so I have a hill to climb it seems…fun times in the drone world