Anyone having bad baro health issues with Arducopter 3.5 and GNSS


(René Desgagnés) #1

Since installing Arducopter 3.5, I can’t seem to get the GNSS barometer working properly. I always get bad baro health. However, if I revert to Arducopter 3.4.6, everything works fine. Anyone has been able to make the GNSS baro works on Arducopter 3.5 ?


(Pavel Kirienko) #2

Hi Rene,

It’s a regression that was brought with the recent changes in the ArduPilot’s CAN stack. I think Eugene Shamaev is already working on fixing that, so it should be improved soon.

For now, I suggest you to keep using with v3.4.


#3

Regarding ArduPilot’s CAN stack i have received following answer few months ago. and obviously @EShamaev and @akolobov @lucamax are aware of it…

"The new CAN stack in the APM does not support dynamic node ID allocation yet, so you will need to configure Zubax GNSS to use a static node ID. Any value from 2 to 125 will work fine. The configuration parameter for node ID is uavcan.node_id, and the commands to set it are as follows: cfg set uavcan.node_id 42 cfg save Paging "

Note that i did not get time to fly my quad since long time… So no experience with 3.5…


#4

hello pavel

i have to upgrade my pixhawk to 3.5.2 version (latest released).

Have u any update to share according to your previous message “For now, I suggest you to keep using with v3.4.”

If not, have you any list of commands that i could apply to check xchange …

let me know


(Pavel Kirienko) #5

At the moment we have no additional information. We’re working on an updated user documentation for APM; the best option at the moment, however, is to nudge the APM developers to get UAVCAN support right. I will be posting updates on this forum when new info becomes available.


#6

hello Pavel

have u any info / update to share. shall we still keep using with v3.4 ?

thnaks in advance for your assistance and advise

alexis


(Pavel Kirienko) #7

At this point, I would advise you to switch to PX4. There are outstanding pull requests in the APM repository that are just sitting there for months and the devs keep ignoring them. Unless their workflow gets changed, I wouldn’t anticipate any improvement in the near time.


(Richard Gardner) #8

Was going to ask if there is any news about getting the Baro working…but seems not. Dang


(Pavel Kirienko) #9

The best sources of information and support about ArduPilot are their support forums and the bug tracker. I will let you know if any relevant information comes my way, but so far there’s nothing new I know of.


(Corrado Steri) #10

Having same problem here, Zubax today answered like this to me:

This is what they wrote to me today:

“I don’t think that’s true. ArduPilot, including v3.5, is known to work with Zubax GNSS 2, as long as its node ID is configured manually. The plug-and-play capability is not supported by ArduPilot still because it doesn’t implement an automatic node ID allocator, but that doesn’t render the device non-usable.”

Not a word about “bad baro health” that everybody is experiencing when using GNSS.

Basically negletting the problem.

Obviously assigning a node ID, wich i did, is not the only problem, as i wrote in another thread, telling people to go complain to ardupilot forums is not a good customer care practice in my book.


(Corrado Steri) #11

I’ll give you an info that Zubax itself looks like doesn’t care to give you. On Arducopter 3.6.RC8 GNSS it is working. At least the bad baro health is not there anymore.
I can’t guarantee that everything is ok tough, i was just about to make some fligh testing when the GPS quit working, no more sats visible. Don’t know if it is related to software but i don’t think so, eveything was looking good with no errors or bad messages and all sensors where working just before GPS went dead.

So you may want to give AC 3.6 RC8-9 a try. Keep in mind it is still a beta so you do it at your own risk.

So looks like there is something new about canbus support on AC, so now Mr Kirienko knows about it too :slight_smile:


(Richard Gardner) #12

Let me know if your gps issue gets resolved.
I am travelling so can try out the code till I get home in a few days.

That is for the heads up


(Richard Gardner) #13

So did you get your GPS working.


(Corrado Steri) #14

Yes i got a new one and i now have 2 GPS and 1 ext compass perfectly working. No more errors.

Today as i was testing my 2 compasses wento zero sat all of a sudden but i was indoor so i guess it was a particular situation. So far everything in working on 3.6 RC10 ChibiOS.

Please read here because i wrote about some recent findings on magnetometer that i think are very useful.


(Richard Gardner) #15

Hey Corrado thanks for letting me know your operational.
I guess I need to make the move to 3.6 RC10 ChibiOS. I would rather wait till its a gold release but if your not having any issues then perhaps I will go for it sooner then later.
I read your comments about the Compass. I have not seen that issue but my gps is held down flat and solid.
But will keep an eye out for it. Since I am making the move to 3.6 RC10 ChibiOS I will need to redo teh compass config anyway so it will be interesting to see how that all goes.

Will let you know. Thanks again for checking back


(Corrado Steri) #16

They just released RC11 with minor adjustments. It is true is a beta but from what dev say it is very close to being released as a stable.


(Richard Gardner) #17

today I got my machine outside to do the compass calibration. I have not done a lot with it as it’s just tossed to many issues at me. But after taking some time away from it I got it outside and tried a calibration.

Much to my surprise I need to set the compass to use number 1. Then I need to ensure external compass is unchecked. Thats the only way to get a calibration in 3.4.6.

The other observation is that the GPs status is 1 meaning I have a gps but no fix. HDdop is 99.99 and no satellites are seen.
I think I may wait for 3.6 to come out and then upgrade to that version. I will then see how it all plays out. Frustrating that no sat’s show up.
Something is definitely wrong I think.


(Richard Gardner) #18

Hey guys out of curiosity which is the zubax.
Anyone know

COMPASS_DEV_ID,66826
COMPASS_DEV_ID2,263178
COMPASS_DEV_ID3,0


(Richard Gardner) #19

So small update this morning.
I upgraded to 3.6.0 RC12 this morning. No more Bad Baro.
I still am getting a hdop of 100, but will get it outside first chance I get to see if it’s just being in doors now.
Also the compass calibration worked…that said it behaves very strangely but it’s done. I hope.
I now get a bad AHRS
I also get "Arm: Waiting for Nav Checks” I have never seen this one.
I suspect I need to redo the accelerometer calibration as I don’t think it happened correctly

More reading


(Richard Gardner) #20

So a bit of reading and a bit of tweaking.

Compass calibration redone…worked flawlessly this time.

No Bad AHRS now. hmmm…compass calibration worked better and suddenly heading issues are resolved…interesting lol

I was having the compass swing slightly with throttle up…that appears to have stopped now. hmmmm.
No EKF warnings on compass either.

Arm: Waiting for Nav Checks are now gone…I redid the accelerometer calibration. good stuff

Still 100 on the hdop…but I am inside…will get it outside as soon as I can…rain rain go away.