Zubax GNSS suddenly stopped working?


#1

I’ve been using a GNSS V2.2 without issue on my pixhawk cube 2.1 with the AP 3.7. I plugged it in today and it won’t pick up any sats. I pulled it off the unit and connected it to Ucenter. Still no GPS sats are found. I have another Zubax from a different drone, plugged it into the cube and it works as it should.
What troubleshooting steps should I take? I’m stumped. Thanks!


#2

I tried resetting in ucenter with these commnads, but it didn’t help.

View, Configuration View, GNSS, then select GPS,Galileo,GLONASS (configure and enable ticks). then hit send, then go to CFG-select all devices and hit send


(Pavel Kirienko) #3

Hello,

Unfortunately, you seem to be another user affected by the one faulty batch of Zubax GNSS 2. I mentioned this problem here before: Second GNSS Zubax gone dead after some time

I suppose you have ordered your units from Titan Elite; may I ask you please to send them an email or call them and ask for either replacement or a refund?

We apologize for the inconvenience. We take quality and reliability extremely seriously, and necessary precautions have already been taken to prevent similar latent failures in the future. If you still have questions or issues contacting Titan Elite, please PM me.