Zubax GNSS and Copter 3.6-rc1


(René Desgagnés) #1

Hello everyone,

Does anyone know if arducopter 3.6-rc1 is supposed to support Zubax GNSS or not ? I’m trying to find the BRD_CAN_ENABLE parameter but it doesn’t exist anymore.

Thanks,

René


(Pavel Kirienko) #2

Yes, ArduCopter does support UAVCAN GNSS modules, but you will need to document the node ID on your GNSS manually: http://ardupilot.org/copter/docs/common-uavcan-setup-advanced.html


(Xie Feng Xi Yu00) #3

Hello, follow the link above to change the code in ArduCopter, enable the UAVCAN protocol, and manually record the node ID on the GNSS. After connecting the Zubaz GNSS after completing the above steps, can we read data?Or do you have a tutorial on the link between ardupilot and Zubax GNSS code?
Thanks
Jinjie


(Pavel Kirienko) #4

The steps you have listed should be sufficient.


(Richard Gardner) #5

Anyone get this working and if so do they get Bad Baro heath warning.
I installed the firmware with out any issues but I get no GPS. From reading I see I need to set the Node id.

Ok I think I am getting closer…lots of digging.
So setting putty at 115200 disables the NMEA output…this is goodness

Excerpt from the Data Sheet.
“Conversely, most other products by Zubax expose physical UART interfaces at the default baud rate value of 115200 baud/second, hence the NMEA output is disabled automatically when the port is opened at this speed in order to ensure compatibility with other Zubax products.”

Configure Putty as follows.

Baud rate 115200
Word size 8
Parity None
Number of stop bits 1
Line ending CR+LF (\r\n)
Remote echo Enabled
Remote line editing Enabled

Ok that got me to the point I could set the Node_ID…but still no GPS on the new code (3.6-rc-3), even after enabling the Can driver.
I set uavcan.pubp-pres to 50000
I set Uavcan Node_id to 42
No go

So I went back to 3.5.5…but thats no good because I still get Bad Baro Health…but I can see the logs
I set uavcan.pubp-pres to 50000
I set Uavcan Node_id to 42
No Go

So back to 3.4.6 …Baro health is fine GPS works. But can’t see the logs. Plus Bad Logging error.I think I can correct the Bad Logging by full format of the SD card.

But even then I can’t see any logs.

I am starting to regret going this direction. Argh


(Pavel Kirienko) #6

Are you still having problems, or were you able to resolve them?


(Richard Gardner) #7

Hey good morning Pavel. hope all is well with you.
as for your question. Nope. It’s really frustrating. Now I confess I am more a hardware guy then a software guy so it could be me just as much as it could be the gps and fc.

For the 3.6 RC3. no joy.
For the 3.5.5 I get bad baro health and absolutely no idea what to do now.
I have raised it as an issue but have little confidence that it will get addressed. I had moved to the GNSS to solve a Pixracer GPS issue that appears to still be outstanding.
Also the GNSS is frankly a a far superior GPS to what I have used in the past and really want to fly it.
I have done everyting I can find to make the baro issue go away
I set uavcan.pubp-pres to 50000
I set Uavcan Node_id to 42
I used the Baro enable script
I set the baro’s up in arducopter…

All to no avail. I can get it all to work in 3.4.6 but it won’t write a log and I won’t fly without a log. I use the log to check everything is setup right and then in the event something goes wrong. The log will help me find out what happened. No log, no fly.

The other thing that I find annoying is that in one code they have these 3 or 4 things to set and the next version its a completely new set…argh

I wanted to move to PX4 but so far have not found out how to do it.

anyway to answer your question, lol,…no its still a problem


(Richard Gardner) #8

Ha I just found out how to do the Px4 install., Going to give it a try.


(René Desgagnés) #9

I went from 3.6-rc1 to 3.6-rc4 and Copter is complaining that I don’t have a 3d fix and bad compass errors. On 3.6-rc1, everything was fine so I assume something important has changed in that release. Anyone else has issues ? I’m using GNSS v1 but I could try GNSS v2 as well to see if it works or not.


(Pavel Kirienko) #10

I think you’ll have better luck asking some of the ArduPilot maintainers directly. Perhaps you could do it here (not entirely sure): https://gitter.im/ArduPilot/CANBUS