Zubax GNSS 2 inaccuracy

Hi. I’ve finally received my Zubax GNSS 2. At first I thought It just needs some time, but it’s running for some hours now. The resolution is extremely terrible.
While having the receiver at a fixed location the the position indicator jumps around by 70m.
Satellite count is 9-12

Also the elevation is very inaccurate. It’s showing values between 308m and 350m.

HDOP 2.0
VDOP 2.9
PDOP 3.7

Best (still off by 40m):
HDOP 1.1
VDOP 1.6
PDOP 1.8

Is this normal? What am I doing wrong?
At first I had it connected to pixhawk via UAVCAN.
Now I’ve connected it to the pc via USB.

Do I have to calibarate something?


Any GNSS receiver is extremely dependent on the quality of signal reception, and hence the clear view of the sky is required for precise positioning. Could you please describe in detail the setup which gave you this result? Was it in an urban canyon or in a room?


The module was located outside on the windowsill in city area. The direct sky view is about 90°vertical and 180°horizontal. Weather is clear at the moment. Tomorrow I will try it with my tablet so it will have the full 180°v and 360°h.
I have the feeling that my previous standard GPS receiver (ublox neo 7) had a better accuracy at the same location?

Thanks for the clarification. These conditions are rather adverse. You will notice significant improvement when you’ll test the module with a clearer sky view.

Sometimes, if the GNSS constellations are arranged favorably and the weather is good (especially at night after sunset), you may get occasional good results even in bad conditions, which could be the case with your NEO 7.

If you could report the result of your outside test here, that would be great.

Wow the accuracy outside is so much better. I’m really impressed:
HDOP: 0.7
VDOP: 1.2
PDOP: 1.4
16 Satellites
Accuracy was about 0.5m when moving (even when moving within 0.5m so that’s what a quadcopter would do trying to compensate the drift). At an absolutely fixed position the accuracy dropped to 1.5m

Thank you.

One question: What’s the reason for the barometer beeing disabled at default for UAVCAN?

Thanks for the report. The reason the barometer is disabled by default is that some users prefer to use the autopilot barometer instead.

Can you tell me why I can’t see HDOP, VDOP, PDOP in Mission Planner or QGroundcontrol? They all seem to be always 0. When ublox NEO 7 is connected the values are all shown.

That’s because APM doesn’t report these values from UAVCAN connected receivers. If you could open a bug report here, it would be awesome: github.com/ArduPilot/ardupilot/issues

Thank you!

Thanks, I assumed that already. I’m running PX4 1.4.4 flight stack (1.5.1 doesn’t seem to find the zubax), so I’d have to file a bug report there discuss.px4.io/. The only problem is that I can’t create an account (no confirmation email) or login with google/github account at their site.
I saw that you already created a post there regarding this login issue for another user.

I would be happy to contribute to px4. I will try to have a deeper look into that issue.
Could it be that issue github.com/PX4/Firmware/issues/5153 ?
I think this should be fixed in 1.4.4

[quote]The only problem is that I can’t create an account (no confirmation email) or login with google/github account at their site.

We should be louder about this I guess. I just raised this issue at their Gitter channel.

Yes, it should be fixed. Could be a regression. Let me know (or re-open that ticket) if you have additional info please.