Unable to connect babel


(Randy Bachtell) #1

I have been using Zubax GNSS since the original GNSS1 and have fought through all the struggles with Ardupilot and the growing pains of UAVCAN implementation. I decided to get another GNSS for a new project only to find that the struggle continues. I found that in order to set a static node id I would need an adaptor that would communicate over serial usb so I spent another $65 just to be able to use my $130 GPS. After fighting installation of UAVCAN GUI tool on my Ubuntu 16.04 machine and my MacBook pro I’m about ready to send everything back. Both machines return the same error “PySerial not imported; SLCAN is not available”. This is after repeatedly installing pyserial and all of the required files. I have searched everything I can find and tried anything that even remotely looked promising on both systems. @pavel-kirienko This should not be this unfriendly, I am not a programmer or fluent with CLI but I have been able to do most everything I’ve needed to do to this point. When your products work, they are great but right now I have a couple of hundred dollars invested in nothing but frustration. Any help would be much appreciated

Cheers, Randy Bachtell


(Pavel Kirienko) #2

Randy,

Sad to hear about your struggles. You are right, our products could use some improvements on the UX front, and we’re actually working on that right now.

Upon quick investigation, I discovered that one of the recent contributions to the UAVCAN GUI Tool project accidentally broke the installation script, which led to PySerial being unavailable. I just released version v0.9.1 where the problem is fixed. If you still have a dysfunctional copy installed, the following command should help revive it:

sudo apt-get install python3-serial

If not, please run this:

sudo apt-get install -y python3-pip python3-setuptools python3-wheel
sudo apt-get install -y python3-numpy python3-pyqt5 python3-pyqt5.qtsvg git-core
sudo pip3 uninstall uavcan_gui_tool
sudo pip3 install git+https://github.com/UAVCAN/gui_tool@master

I found that in order to set a static node id I would need an adaptor

Observe that you can also set a static node ID using the USB CLI. The only thing that is needed for that is a micro USB cable. You can fine more information here:

Hope this helps!


(Randy Bachtell) #3

SOLVED @pavel-kirienko. Thank you very much for the quick response and fix, the ‘python3-serial’ fixed the connection issue and I now have a redundant GNSS2 system on my test vehicle. The “CANbus for the rest of us” on the Ardupilot wiki made setting node id easy. Next will be implementation of UAVCAN ESC’s. Thanks again Pavel

Cheers, Randy Bachtell