Switching from Orel 20 to Myxa, is my Motor no longer compatible?


(Roger Smith) #1

I am using this motor for some testing with Myxa. it was fine with orel 20.

Any idea what to try?

2 Pole motor

The Kuther output.

Myxa Output.pdf (260.3 KB)

When I attempt to run the simple script that sets the output speed based on a sine wave, I get no output. Not sure why the voltage is 0 (zero). It’s seeing voltage.

error_count: 0
voltage: 14.5078
current: 0.0000
temperature: 302.0000
rpm: 0
power_rating_pct: 0
esc_index: 0

Message from 125 to All ts_mono=10.583595 ts_real=1539497442.124591

error_count: 0
voltage: 14.5078
current: 0.0000
temperature: 302.0000
rpm: 0
power_rating_pct: 0
esc_index: 0

Message from 125 to All ts_mono=11.083584 ts_real=1539497442.624548

error_count: 0
voltage: 14.5078
current: 0.0000
temperature: 302.0000
rpm: 0

*** Here is what I see when the same script is run with the motor connected via orel 20 ***

error_count: 0
voltage: 14.5469
current: -0.0037
temperature: 305.0000
rpm: 0
power_rating_pct: 17
esc_index: 0

Message from 125 to All ts_mono=9.854641 ts_real=1539493940.877201

error_count: 0
voltage: 14.5469
current: -0.0082
temperature: 305.0000
rpm: 50
power_rating_pct: 17
esc_index: 0

Message from 125 to All ts_mono=9.954653 ts_real=1539493940.977199

error_count: 0
voltage: 14.5469
current: -0.0089
temperature: 305.0000
rpm: 78


(Pavel Kirienko) #2

In order to be able to work, Myxa needs to know the parameters of the connected motor. From your screenshot I see that you did not specify the motor parameters and did not run the motor identification procedure. Please follow this guide: Quick start guide for Myxa v0.1 If that doesn’t work for some reason, please post questions here.


(Roger Smith) #3

Thanks for the quick response. I’ll try that shortly, BTW, it seems like the video you uploaded at that link, never did upload properly as it says a length of 0 secs.


(Pavel Kirienko) #4

The video works for me. If you can’t view it in the browser (we can), try downloading it first.


(Roger Smith) #5

Ah ha…it is a .webm video . Firing up Google Chrome works. Video is extremely helpful, will follow those steps shortly to setup my motor.


(Roger Smith) #6

After setting the motor parameters (number of poles, max current) and running it through the initial setup, it all works!! Since I can now compare the Orel 20 vs the MYXA back to back, there is a noticeable difference in how the motor ramps up and runs through the sine wave test.

Thanks!