Homepage Knowledgebase GitHub

RPM Control Mode

Hello,

I am using Myxa to control the motor in RPM via PWM. I did an endurance test on my system and I observed that the RPM is not constant during the mission and decrease with the tension of the battery. The current should increase to keep the same power.
The Myxa is configure to RCPWM control mode at 1 (RPM).
Maybe I have misconfigured something.
zubax_config.yml (1.9 KB)

image

Hi @ftanguy. Your configuration parameters seem to be correct. The max speed is proportional to the battery voltage as described in section 3.1.1 in the datasheet. m.max_eangvel parameter just defines the max setpoint value. I.e. in the ratiometric rpm control mode, the setpoint equal to 1 corresponds to the rpm setpoint value equal to m.max_engvel. However, the real max speed can be lower than m.max_eangvel. Since the real maximum speed is proportional to the battery voltage, in this case, you will see the motor speed decrease as the battery voltage decreases.

Hi Dmitry,

Is it possible to have a constant RPM with a constant PWM command for any battery voltage?
We need to have the same speed at a PWM command for any battery voltage.
It will be tricky if we have to compute the PWM command depending on the battery voltage.

Hi,

You can set m.max_eangvel parameter to the maximum electrical angular velocity at the lowest battery voltage. Your max rpm will not depend on the battery voltage then.

I don’t understand the link with the m.max_eangvel.
We want a constant RPM, so the eangvel should be also constant.
During the test, the eangvel decrease with the RMP and the battery voltage.
At the begin, we have an eangvel of 1500, and the eangvel should be at 1500 during all the test (the m.max_eangvel configured is 10 000).

image