Orel 20 with PX4 can only work after using GUI TOOLS


(bones) #1

after connected and arm pixhawk , the moter didn‘t work.
then i connect the babel and GUI TooL , run dynamic node id allocation server
, the moter works.
should i use dynamic node id allocation server in GUI TooL everytime?


(Pavel Kirienko) #2

You have two solutions:

  1. Assign the node ID values manually for each ESC. By default the node ID parameter is set to zero, which means that the device will attempt to allocate a node ID manually; any non-zero value will be used as the node ID instead of relying on the dynamic allocation procedure.
    2.Enable the dynamic node ID allocation server on PX4.

(bones) #3

Thanks Pavel,
I want to know how to Enable the dynamic node ID allocation server on PX4?
how can I use orel20 esc without pc or babel


(Pavel Kirienko) #4

The server is enabled automatically when you set UAVCAN_ENABLE to 2 or 3. In your case you need to use 3, seeming as you are not using RCPWM-controlled ESC.

If the above setting doesn’t help, PX4 probably runs out of memory. A possible remedy is to disable all unnecessary software components of PX4 in order to free up some memory. If that doesn’t help or is impossible, consider using static node ID instead.

I recommend reaching out directly to the PX4 support forum for help with that, as we don’t really provide direct support for third party systems.