Issues with flashing Zubax Babel & UAVCAN GUI Tool


I recently got a zubax babel, I am trying to flash firmware on to it, to make it usable. OS on my computer is Ubuntu 18.04,
I have been following instructions on: GitHub - Zubax/zubax_babel: High performance CAN-USB/CAN-UART adapter + UAVCAN devboard

And the flashing process seems to be going on forever. I have this message saying "Ymodem sectors/kbytes sent: 97/12k " and this process does not seem to be ending. I left it overnight and this process did not./ get completed. I have connected Babel to my computer using USB/Serial port. /dev/ttyACM0 and I am running script.

Another issue I am facing is with the UAVCAN gui tool. I have followed the instructions on: GitHub - OpenCyphal-Garage/gui_tool: Legacy cross-platform GUI application for UAVCAN/CAN v0 bus management and diagnostics. Does not support UAVCAN v1; for that, see Yukon.. it seems to have installed cleanly without throwing any errors. Bu when I execute the command uavcan_gui_tool, I get an error saying importlib_metadata.PackageNotFoundError: No package metadata was found for uavcan-gui-tool.

I have attached some screenshots and images of the issues I have been facing.

Can someone please help me out here?

  1. Regarding the flashing issue: according to the logs you shared, you have modified either the bootloader, the uploader script, or both. We cannot provide support for your custom software for obvious reasons.

  2. Re UAVCAN issue: I am unable to reproduce this. Can you please wipe the tool along with all its dependencies from your system, and then share the exact steps you have taken to install it, down to each executed command? You may have a damaged/malfunctioning Python on your system.

Hello Pavel,

Thank you so much for your response. For the response 1, in main.cpp , it looks for gcc version 6.3.1. I am on ubuntu 18 and unable to find the link to download gcc 6.3.1., I currently have gcc 6.5 installed on my computer. I got that error, because I commented the line where it was checking for the gcc version. But, I think that broke my code. Is there any other version of code available which uses later versions of gcc? Or can you please provide me links to where I can find gcc 6.3.1?

GitHub - Zubax/zubax_babel: High performance CAN-USB/CAN-UART adapter + UAVCAN devboard is the repo I trying to use to flash my zubax bable via usb.

Thank you,

Viresh Duvvuri


Just wanted to follow-up on my previous post. Thank you.


I tried flashing Zubax Bable, using the virtual linux machine - bistromathic, but it again seems to be stuck in a loop. I did not change anything in the repo this time. I built the repo and then I am trying to flash it with the command firmware/zubax_chibios/tools/ . The bytes are getting transferred to the bootloader, but it seems to be taking forever. I have attached the screenshot below:

I would really appreciate if someone could help me solve this issue.

Thank you,

Viresh Duvvuri

You can download any version from Downloads | GNU Arm Embedded Toolchain Downloads – Arm Developer

To set it up, follow GNU ARM embedded toolchain - Knowledge Base - Zubax Knowledge Base

You are using the upload script incorrectly. Run it without arguments to see the correct usage (the first argument should be the firmware file, not the port).

Thank you so much Pavel. It all works now.

I have just started working with a couple of babels. When I connect them via usb there are no lights and no usb devices are enumerated (such as a usb-serial interface). Is this the expected behaviour?

Ah - just found one of the cables they shipped with was bad. Should be back on track now :slight_smile: