Homepage Knowledgebase GitHub

Issue for connection with virtual port with Linux Kucher application

I am trying to connect Zubax with Kucher (Linux application) thanks to a virtual port.

The virtual port is created with this command :

sudo socat PTY,link=/dev/ttyUSB5,raw,group-late=dialout,mode=660 TCP:192.168.31.20:5005

I am able to connect to Zubax via pySerial. Do you have a command to send to Zubax to know if I can interact with it via pySerial?

Kucher (Linux application) do not looking for virtual port, so I forced the virtual port inside the application code (selected_port variable inside kucher/view/main_window/device_management_widget/__init__.py) and I have an error when Kucher try to communicate with Zubax. This is the error:

2020-06-11 11:33:07,137 pid=12930 ERROR: kucher.view.utils: Error window: title='Could not connect', text='Connection via the port /dev/pts/6 could not be established.', informative_text='Reason: Node info request has timed out', parent=<kucher.view.main_window.device_management_widget.DeviceManagementWidget object at 0x7fb037f13d38>
Traceback (most recent call last):
  File "/home/florian/Téléchargements/kucher/kucher/view/main_window/device_management_widget/__init__.py", line 222, in _do_connect
    device_info: BasicDeviceInfo = await self._connection_request_callback(selected_port)
  File "/home/florian/Téléchargements/kucher/kucher/fuhrer/__init__.py", line 66, in _on_connection_request
    device_info = await self._device_model.connect(port_name=port, on_progress_report=on_progress_report)
  File "/home/florian/Téléchargements/kucher/kucher/model/device_model/__init__.py", line 135, in connect
    general_status_update_period=DEFAULT_GENERAL_STATUS_UPDATE_PERIOD)
  File "/home/florian/Téléchargements/kucher/kucher/model/device_model/connection.py", line 301, in connect
    raise ConnectionAttemptFailedException('Node info request has timed out')
kucher.model.device_model.connection.ConnectionAttemptFailedException: Node info request has timed out

Please see this: Short coding example for serial interrogation of Myxa

The serial tunnel is not working or its latency is too high so Kucher gives up waiting before the response is recevied.

I tried at different baudrate to communicate with Zubax (115200, 230400 and 460800) but I have the same error during the connection between Zubax and Myxa.

Okay, but when you say that you are trying to communicate with “Zubax”, what do you mean exactly? What is “Zubax” here?

I mean Kucher, the connection between Myxa and Kucher.

The baud rate doesn’t matter. Your tunnel appears to add too much latency or it causes data corruption, you should fix it.