Initial setup


(TõnuTunnel) #1

Hi!

I’m a bit new to the topic. I’ve just received and connected ny Zubax GNSS v2 (red board) to my pixhawk (running PX4). It seems to be working fine and I get way more satellite locks even between buildings and even indoors. And lockon after a reboot is almost instataneous - awesome.
Do I need to calibrate the Zubax board from time to time or does it handle itself somehow? Also in the documentation you state that the zubax’s barometer is turned off by default? Makes sense to enable that, no? Why is it disabled at first place :slight_smile:


(Pavel Kirienko) #2

Hi Tonu,

The only thing you need to calibrate is the compass, and that only if you’re using it at all. The calibration procedure is defined entirely by your controller which you connect Zubax GNSS to; Zubax GNSS just outputs raw measurements of the magnetic field strength (like all compasses do).

The barometer is disabled by default because many users opt into using the barometer embedded into their hardware (e.g. autopilots). Having it disabled by default is a safer and less intrusive approach.


(TõnuTunnel) #3

Odd. I did the usual gps calibration over qgroundcontrol and now its somehow messed up.

[13:19:14.018] Info: [inav] GPS signal found
[13:19:15.124] Info: [inav] init ref: 59.4427619, 24.7337152, 16.7010
[13:19:16.648] Critical: Not ready to fly: Sensors not set up correctly

But the pixhawk keeps blinking red and I get an alert that not all sensors set up correctly. Also the double blink on the zubax gnss not single 1Hz.


(Pavel Kirienko) #4

Do you think you could be affected by this bug in PX4? github.com/PX4/Firmware/issues/4780


(TõnuTunnel) #5

Hmm. Sounds similiar indeed. Any way of manually prioritizing or even completely disabling the internal compass?


(TõnuTunnel) #6

I reinstalled PX4 and recalibrated all the sensors and now it seems to work fine. Not sure if some updates have been made meanwhile. Odd. Hopefully weather clears up and I can go flying and see how it performs and if the issue reappears.