How to recover a Flash gone bad? DroneCode Probe?


(Roger Smith) #1

One of my Orel 20’s ESC’s is stuck in initialization, after attempting to update the firmware. I flashed it via a babel board and uav_gui_tool.

Would a DroneCode probe allow me to kick it and reflash it? Is there a suggestion on how to kick it out of this mode? It was working until I decided to update it from version 1.0 firmware to version 2.0 firmware.

ESC stuck in initialization

Another Orel 20, I flashed worked! It was the the same firmware I tried to load onto the one that failed. They were both running 1.0 firmware.

Good Flash

Is a DroneCode probe https://kb.zubax.com/display/MAINKB/Dronecode+Probe+documentation the best way to flash the OREL ESC’s going forward?


(Pavel Kirienko) #2

There should be no problem with the embedded UAVCAN bootloader, so in your case there is no difference between the Dronecode Probe and the bootloader. Perhaps that one ESC failed to update because the file transfer was interrupted at some point. Currently it has no valid firmware so it’s just sitting in the bootloader; to fix it, just update its firmware again, and it should go back to normal.


(Roger Smith) #3

Hi Pavel,

There wasn’t any interruption during the firmware update (This is on my bench using a DC power supply set to 14 volts)… Unfortunately the gui_tool now reports " request timed out when trying to update the firmware again, even after clicking several times in a row.

Can you confirm which binary from https://files.zubax.com/products/io.px4.sapog/ I should be flashing on my Orel 20’s? Should I be using *.application.bin or *.compound.bin?

Is there a topography to connecting the canbus to the babel board, and powering the board that you recommend?


(Roger Smith) #4

An update: I was able to flash both of my Orel 20’s with io.px4.sapog-1-2.3.fa0ff46.application.bin using the gui_tool. I am back up and running now.