How to Enable Orel 20 PWM Control


(Keenan Johnson) #1

I’m trying to get an Orel 20 working with PWM control from a motor thrust test stand.

I soldered on the PWM connections to the board holes described in the datasheet, but I’m unable to command the motor controller.

When I power it on, the controller does a self check and reports a green status. However, it doesn’t appear to respond to any of the PWM signals.

Do I need to do anything special to enable the PWM mode?


(Pavel Kirienko) #2

Hi Keenan,

Please set the config pwm_enable to 1. More info in the section 4.3 here: https://files.zubax.com/products/io.px4.sapog/Sapog_v2_Reference_Manual.pdf.


(Pavel Kirienko) #3

Also, note that you can’t use UART and RCPWM at the same time. This is explained in the section 2.5.2 in https://files.zubax.com/products/io.px4.sapog/Zubax_Orel_20_Datasheet.pdf.


(Keenan Johnson) #4

Ah I totally missed that in the guide. Is the only way to set that from an external CAN adapter?

I’m asking if I can somehow set it from a Pixhawk flight controller somehow?

Thanks!


(Pavel Kirienko) #5

No, you can set the parameter using UART, but then please disconnect from UART before rebooting the controller.

You can change configuration parameters using QGroundControl if you’re using PX4. If you’re using APM, there’s currently no way to do that, but you can use a dedicated CAN adapter such as our Babel instead.