GPS point issue - RaccoonLab GPS MAG BRO V2.3.2 - Cyphal testing with Yukon

can log.txt (101.2 KB)

Hi everyone,
Could anyone help me on this, I’m new. I’m trying to use RaccoonLab GPS MAG BRO V2.3.2 module, using Yukon tool to monitor data on Cyphal, looks everything is goood but for GPS Point is wrong, it reported longitute, altitude and latitude are all zero value. - see can log and vdo

Anyone have any idea? Did I do anywrong?
Thanks in advance!

Hello, thank for the information. We can see here that the MCU is receiving NAV-PVT packets but without coordinates from the U-BLOX. To clearly understand what is happening, I would like to ask the following questions:

  • Do you have a clear view of the sky? Are you sure the GNSS signals were coming at that time?
  • Can you tell how the LEDs are flashing? Is it flashing blue?
  • Just in case, do you have this version of GNSS?

Hi @sainquake , thanks for replying me

I kept the module near to the window in long-time, I have not worked on GPS module yet, not sure how its data is sent to STM32F103 MCU on the board. I’m trying to understand. Onemore, I connected uart port and show the data on PC, but there is no helpful logs by some common baudrate, even 9600 is mentioned in datasheet. the log is as bellow

All leds are flashing blue at all time.

I tried with the default firmware and even v1.5.6 Cyphal firmware is which I used to reflash.

To view the data transmitted on the UART bus, install u-center (not u-center 2!) from u-center. Connect using a baud rate of 921600.
This program allows you to view decoded messages from u-blox. To view all packets that are being transmitted, simply open the ‘Messages View’ by selecting ‘View’ from the menu bar.

The problem is clear to us. The issue is on our side, and we will send you a new device as soon as possible. After double-checking that it is working perfectly.

I’ll keep you informed.

@sainquake these are my trying as your suggestion, looks like a problem with UBlox module, isnt it? I’m looking for something coming on u-center tool, but longitude, altitude, latitude are all zero same as shown on cyphal.

Hello, your new device is already on its way to you.

@sainquake New device just arrived. I tested with it, seems that an issue on firmware, UBlox has gps data when I checked with uart and ucenter tool. but no valid data on CAN - observed on Yukon. I live in VietNam.

Can you please help me to check and give your suggestion.