GNSS2 don't work with arduplane 3.5


#1

Hello, I bought two zubax gnss2 for two of my planes to renplacing the zubax gnss1 but when plug and turned on my plane with pixhawk and AP 3.5 and AP 3.6, mission planner detected GPS but don’t fix possition, the all leds are ok on red board.
I erased on CLI mode but all continue equal.
I need some tips, thanks.


(Pavel Kirienko) #2

Make sure that UAVCAN is enabled on APM. Also you may want to make sure that your GNSS are not damaged, see this post viewtopic.php?f=4&t=22#p94.


#3

Just now I try to qgis connect and work fine.
On APM I had GPS_TYPE = 9 and BRD_CAN = 1 (on param list only give me two options 0 or 1 not 2, with 2 CAN1 led didn´t blink, but with 1 blink ok)


(Pavel Kirienko) #4

You either need to set BRD_CAN to 2, or you’ll have to manually set the parameter uavcan.node_id on Zubax GNSS 2 to any integer from 2 to 125, inclusive.


#5

ok thanks I’ll try it.
When I set BRD_CAN to 2 de green led (CAN1) didn’t blink.


(Pavel Kirienko) #6

That could be caused by your Pixhawk running out of memory. If you can reliably reproduce this issue, I suggest to disable some unused applications. Although a simpler solution is to assign the node ID manually as I described above.


#7

I just set node manually an test with list comand but continue without gps data on mission planner :confused: , and all leds on GNSS2 are ok. (PPP blink, CAN1 solid or rapid blink, STATUS blink at 1hz
BRD_CAN = 1
GPS_TYPE = 9


(Pavel Kirienko) #8

Thank you. This looks like an APM issue. I suggest you to open a ticket on the APM support forums, e.g. here github.com/ArduPilot/ardupilot/issues.


#9

I tryed with 3 diferents pixhawks and 2 GNSS2 (no hardware problem), however with zubax GNSS1 all work fine :confused: .
I’m going to post here, thanks


#10

Hello,
Just wanted to let people know that we had the same problem described above with the GNSS2 board, and a pixhawk running arduplane 3.6.0

As Pavel suggested that it might be running out of memory we tried a different pixhawk, this worked and we have a reliable GPS fix and we have a theory which we haven’t confirmed at this point:
The theory is that the pixhawk may have been an early version, where despite the CPU having 2MB or flash space, only about 1MB was available as per the link (diydrones.com/forum/topics/pixha … lash-limit)
You may want to see if you’re using an older version of the board and then try and free up some memory.

Just to re-iterate, we have not been able to confirm this is the cause however it’s the best theory for us as to why two virtually identical sets of firmware have produced different results.

-Adam


#11

Adam, thanks for your reply. I’m trying to test my pixhawk like Randy explain on your link but I can’t connect any of my boards by NSH :blush:
One of my pixkawk is 3RD original and the other two are clones buyed this month.


#12

Some one knows other way for test if my problem is out of memory.


#13

Pavel, nobody response me on github github.com/ArduPilot/ardupilot/issues/4449, could you post something here like Zubax people?
Anyone have the same issue? I’m the unique with this issue.


(Pavel Kirienko) #14

Sorry about the ArduPlane issues. Maybe you will have better luck with ArduPlane 3.6? If not, I suggest to disable all non-essential features, such as extra MAVLink instances etc.


#15

I tried before with AP 3.6
Do you want to said SR0 and SR1?
Thanks


(Pavel Kirienko) #16

You should try to disable all auxiliary functionality of APM and test again; for example you could temporarily wipe your configuration and SD card and setup it to work with Zubax GNSS 2 from scratch. If this does help, then you definitely have a memory issue as I described above. If this doesn’t help, maybe you should consider switching to PX4?