Error compass Variance


#1

Hi family,

I was trying to flight my little drone with Zubax GNSS, I used Mission Planner 1.3.32 and firmware ArduCopter V3.3

I followed all steps from here:
http://docs.zubax.com/Zubax_GNSS_tutorial:_Using_with_Pixhawk#Configuring_Pixhawk_with_APM_firmware

Then, I calibrated accels and compass. All it was fine and looked ok.

However, when I went to get my first flight, appeared “Error Compass variance”. I tried to calibrate again, but without success.

Could you help me?

Thanks very much.

WEIWEI CHENG


(Pavel Kirienko) #2

Hi,

You said that you can’t calibrate again - what error is preventing you from doing so?

Also, have you placed Zubax GNSS close to large metallic parts or high current conductors?

Pavel.


#3

I got the same error all time. Also appear “Bad AHRS” at the same time than “Error Compass Variance”.

I tried to calibrate, but this 2 messages continue appearing on my screen. Anyway, I tried to flight in Loiter mode, but the copter has circle movements and it is unstable.

Also, I put My Zubax on the GPS Support, so it is quite far to the Frame and connectors.


(Pavel Kirienko) #4

Ok, I see. This looks like an APM issue. I googled a little and found the following two threads relevant:

The problem could be caused by incorrect orientation of your Zubax GNSS, so that APM is receiving contradictory readings from its two magnetometers (internal and external), triggering the warning. Please make sure orientation is correct, then retry. If it still doesn’t work, I’d recommend to ask your question on APM forums and put a link to your thread here, so I could follow the discussion too.

Thanks.