Control of 4 Orel boards with Babel: UAVCAN Node Setup


#1

Hi Pavel,

I have 4 Orel 20 boards connected to 4 motors.
The first board is connected to a pixhawk (which is not powered on) and then daisy chained through boards 2 and 3 to board 4.
Board 4 is connected to a Babel and terminated.
(All of this is on CAN1).

In UAV GUI Tool, I have the Babel Node ID set to 127 and the Orel boards have Node ID’s 122, 123, 124, and 125 from the dynamic node id allocation.

When I use the ESC Panel in UAVCAN GUI Tool, the first slider spins all 4 motors and sliders 2 - 4 have no effect.

I have tried setting “esc_index” and “light_index” differently (0 for 122, 1 for 123, 2 for 124, 3 for 125) for all 4 motors.
Still, all 4 motors spin.

After the dynamic node id allocation I noticed that “uavcan_node_id” is 0 for all 4 Orel boards (under “Node Properties” -> “Configuration parameters”).
I have tried setting these values to match the automatically allocated Node ID’s but all 4 motors still spin when I move the first slider.

Can you please explain the proper way to configure 4 Orel boards?

Thaks!

Derek


(Pavel Kirienko) #2

Hi Derek,

You need to reboot Sapog in order for configuration changes, such as setting new “esc_index”, to take effect.

This is because by default, “esc_index” is set to zero.

[quote]I have tried setting “esc_index” and “light_index” differently (0 for 122, 1 for 123, 2 for 124, 3 for 125) for all 4 motors.
Still, all 4 motors spin.[/quote]

This is because you need to reboot the ESC after you changed its configuration. Also please make sure to save the configuration once you changed it (“cfg save” if you’re using CLI, or the button “Store All” if you’re using the GUI Tool).

This is expected. The configuration parameter “uavcan_node_id” does not reflect the current node ID of the node. Furthermore, node ID has no effect on the ESC index assignment.

So what you need to do is:

  • Configure ESC index
  • Save the configuration
  • Reboot the board