Homepage Knowledgebase GitHub

Can't connect to PX4 system console using Dronecode probe

I just purchased a Dronecode Probe. I tried connecting to the PX4 System console on a Pixhawk 4 FCU and couldn’t do it. I have never used any JTAG device before, so I’m not entirely sure what to expect. But here’s the behaviour that I observed:

First I followed the instructions on this page: https://kb.zubax.com/pages/viewpage.action?pageId=2195511
After that when I use cat /dev/ttyACM0 nothing happens. There is absolutely no output and I can just press CTRL+C to quit. Is it supposed to be like this?

Afterwards I followed these instructions: https://kb.zubax.com/display/MAINKB/CLI+client+software
Again nothing happens. I can start picocom and “connect” to the device. At least picocom doesn’t complain about the device not being connected or anything like that. I tried picocom /dev/ttyACM0 -b 115200 as well as picocom /dev/ttyACM1 -b 115200. For both commands picocom startet, but except for that nothing is happening. Again I’m not exactly sure what I should expect to happen. I expected that I can use the command shell similarly to the Mavlink Command Shell from QGroundControl.

Can Anyone help me with this?

JTAG and the system console are absolutely unrelated. The system console is just a UART port. The USB-UART bridge is exposed by the second interface of the Dronecode Probe, not the first one, so you should use /dev/ttyACM1. The baurdate of the PX4 system console is 57600. Check the wiring and make sure the console is enabled at all (we will not be able to help you with that, refer to the PX4 docs).

Yes, I also had read, that it’s ACM1, but then here you use ACM0 as an example. So I thought, I’d better make sure and try both.

What do you mean by “check the wiring”? I mean, I just plugged in the USB cable from my computer to the dronecode probe and then the JST-SH cable to the debug port of the pixhawk 4.

So what, this example has nothing to do with Dronecode Probe, it is generic.

I mean, make sure the electrical connections are secure and that you are using the correct UART port.