Homepage Knowledgebase GitHub

Data acquisition via USB

Hello everybody!

I just bought some Myxa A2 ESC, and I have 2 questions:
I am using it via USB on Windows at the moment, but I also have ubuntu.
I am wondering if there is the possibility of acquiring data that are showed in the Kucher window while running the motors.
Moreover, I am looking for a brake function for the ESC. I simply need that it stops the motor rotation when move the throttle to idle.

Thank you all!


You can acquire data in Kucher while running the motors. You can connect Myxas via UAVCAN cable to PC or to the autopilot and control in UAVCAN GUI Tool as well.

The ctl.hard_stop is exactly the parameter that enables this feature.
You can find more information in the Quick Start Guide.


thanks for your reply.

I am now controlling the Myxa from PC via USB connection, because making wind tunnel testing.
I set the ctl.hard_stop to true , but when I stop the motor the ESC does not block the rotation, but it freewheels.
How can I solve?



Sorry, I probably didn’t put it very clearly. The ctl.hard_stop should be set to false. And control the ESC in ratiometric voltage control mode or ratiometric speed control mode.


thanks again for your reply.
I am sorry but I can’t do this. I recap:

  • I have Myxa A2, coupled with electric motor Dualsky XM2838 running on 4S.
  • I control it by now via USB and windows PC, but in the future I will use UAVCAN in the flying setup.
  • I made several run in the wind tunnel and I can clearly see the motor braking when, for example, I set a high wind value in the tunnel and a low RPM setpoint in the software.
  • I tried controlling the motor in Radiometric RPM, Mech RPM, Radio Current or Current mode, I tried with hard_stop set both to ‘False’ and ‘True’, but if I insert zero in the setpoint, or if I hit stop, the motor simply freewheel (also increasing RPM number if I was braking), while I would like it to stop.

I attach a screenshot, maybe I am missing some parameters.
Thank you very much


Let me describe the principle of hard stop and non-hard stop. Hard stop means that when the device receives a near-zero setpoint or the Stop command, it switches off all the mosfet transistors. The motor is then stopped on its own, in a non-controlled manner, until the drivetrain runs out of energy. By default, this option is disabled, which means that the device will not relinquish motor control until the motor speed has fallen down below the minimum (m.min_eangvel).
In your case, the possible reasons for the slow braking of the motor are:

  • Not tuned PID speed controller in the speed control mode. As I can see you are using the default gains.
  • High m.min_eangvel parameter value, which causes controlled braking to be switched off too early.

Ok, Thanks for the feedback.

How can I try to solve? Before running the motor the first time I did “motor identification” and “self test”, so I thought parameters were fine. I could try lowering min_eangvel, if the motor keeps running smoothly, but what could for the PID gains?


You can find the instructions for the speed loop tuning in the Quick start guide or in this post.

Thank you very much, now it is much better!